読者です 読者をやめる 読者になる 読者になる

機械学習, Rails, Androidが好きです - プログラマdogwood008のライフハック

最近のマイブームは機械学習, Ruby on Rails, Android、中でも機械学習を使った金融商品の自動取引に興味があります。

Rails3のプロジェクトをRails4へアップグレード

1. Gemfileを編集して,Rails3を使用するよう設定してある部分をRails4を使用するよう変更

Rails3を使用する設定を
gem 'rails', '3.2.XX'
Rails4を使用する設定に変更
gem 'rails', '4.0.2'

2. Rails等の依存関係を修正
bundle install

3. 正しく動作するか確認
rails s


※「DEPRECATION WARNING: config.whiny_nils option is deprecated and no longer works.」が表示された場合, Rails.root/config/environments/*.rbをRails4用のものに差し替えれば良い.
今のRails3のプロジェクトと同名で別ディレクトリにRails4を使用して,
rails new PROJECT_NAME
で新プロジェクトを作成し,当該ディレクトリのファイルをコピーすれば良い.
参考:http://qiita.com/shu_0115/items/929396bc915db909da26